Tuesday, April 22, 2008

Not responding...

I went in today for my first Estradiol blood test since starting the Follistim. I received the call from the nurse this afternoon that I'm not responding to the Follistim as I should. My levels were below 20 before starting the Follistim and are now only up to 28 after being on it for 2 days. They are up'ing my dose to the maximum which is 450 units. I'll do this for the next 3 days and then go back on Friday morning to have blood drawn again. The nurse said that it could be low due to the fact that I have only one ovary.

Pray that this dosage increase works and that my estrogen level will increase...otherwise, they will cancel this cycle and we will have to start over with new protocol.

I'm bummed....

6 comments:

andrea_jennine said...

Oh, I'm sorry for the disappointing estrogen level. Hopefully the new dose will do the trick...

Hope said...

I am so sorry about your labs, I hope the increase in dose will work and kick that ovary in gear!

lotsa prayers your way!

Mel said...

Oh man, that stinks... I sure hope that ovary wakes up and gets it's act together pronto!
I will say on my last month of stims that my ovaries wouldn't respond for the longest, E2 levels stayed flat for almost 2 weeks. But when they finally took off, it happened so fast.
Saying a little prayer for you.
*hugs*

gracechild said...

oh sweetie, I know how that low e-level report can be like a kick in the gut. Praying for you & I hope a positive report comes soon.

sara said...

I'm hoping that your ovary starts stepping up to the plate. I'll give it a pep talk for you, OK? I hope things start rising as they should...I'll be thinking of you.

mrsandrewweaver said...

Bless your heart! I'm sorry sis. I can't imagine having to go through all this to have a baby. I just know that God will bless you with a child someday - I just pray that someday is soon. I love you.